R/C Fun & Long Overdue Topics Coming!!!

Once again life made me busy and sadly, it didn’t leave me time to blog, until now. Let me get right back into it with some news on what happen with  my 1/16th Slash a couple weeks ago. For a while, I’ve noticed a loss of performance with the truck, as if it wasn’t charged. Then, it’d speed up, slow down, speed u and slow down, like the batt. had a bad connection.

 

Well, two weeks ago, I ran the Slash and flipped it, but when I turned it bacck on it’s wheels, the truck acted like the gears became disconnected from the motor, because the electronics were working, but the truck didn’t wanna run. Looking back on the run, it was a bad flip, flipping twice, then boom! Called the hobby shop, explained the issue and they thought the same, (gears separated from motor).

 

Well, because of the MTA Your Ride fooling around, my trip to the hobby shop didn’t happen until last week. When I got there, they tried it, telling me the motor maybe bad, which made sense, the truck is two years old & seen abuse, but… When the guy tried a new battery, the Slash ran, like a boss!!! Here I thought the worst, when it was the pack giving out completely! Bought a new battery and I’m happy to report that the Slash is back ripping up the streets! 🙂

 

Oh, my plan is to buy one more batt. as a second pack next month. Onto other news: Though busy, a lot of good topics came to mind, so please stay tuned! 🙂

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s